CVE-2024-11828 Inefficient Algorithmic Complexity in GitLab

Medium 4.3 Published Updated

An attacker can cause a denial of service in GitLab by sending crafted API calls due to inefficient algorithmic complexity.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-11828?

CVE-2024-11828 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 26 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A denial of service (DoS) condition was discovered in GitLab CE/EE affecting all versions from 13.2.4 before 17.4.5, 17.5 before 17.5.3, and 17.6 before 17.6.1. By leveraging this vulnerability an attacker could create a DoS condition by sending crafted API calls. This was a regression of an earlier patch.

Weakness: CWE-407

Which versions are affected by CVE-2024-11828?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.2.417.4.5, 17.5.3, 17.6.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-11828?

Upgrade gitlab to a fixed version for your release line: 17.4.5, 17.5.3 or 17.6.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-11828 being exploited?

There is no known exploitation of CVE-2024-11828 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-11828, GHSA-rmhm-cwgp-268p, UBUNTU-CVE-2024-11828.

Is CVE-2024-11828 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free