# CVE-2024-11916: Missing authorization in The Ultimate WordPress Toolkit – WP Extended

> Authenticated subscribers can exploit missing authorization checks to inject malicious scripts and modify data in the WP Extended plugin.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Jan 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-2235-g2f2-vp6c

## What is CVE-2024-11916?

CVE-2024-11916 is a high-severity missing authorization vulnerability in wpextended The Ultimate WordPress Toolkit – WP Extended, published on 8 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The The Ultimate WordPress Toolkit – WP Extended plugin for WordPress is vulnerable to unauthorized modification and retrieval of data due to a missing capability check on several functions in all versions up to, and including, 3.0.11. This makes it possible for authenticated attackers, with subscriber-level access and above, to import and activate arbitrary code snippets along with

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-11916?

It affects 1 product.


Products: Wpextended Wp Extended.

## How do I fix CVE-2024-11916?

No fix has been published for CVE-2024-11916 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-11916 being exploited?

There is no known exploitation of CVE-2024-11916 in the wild and no public exploit code.

## Other vulnerabilities in wpextended The Ultimate WordPress Toolkit – WP Extended

- [CVE-2024-8102](https://insights.sbomify.com/CVE-2024-8102/): The Ultimate WordPress Toolkit – WP Extended <= 3.0.8 - Authenticated (Subscriber+) Arbitrary Options Update (high 8.8)
- [CVE-2024-8104](https://insights.sbomify.com/CVE-2024-8104/): Path traversal in The Ultimate WordPress Toolkit – WP Extended (high 8.8)
- [CVE-2024-37259](https://insights.sbomify.com/CVE-2024-37259/): WordPress WP Extended plugin <= 2.4.7 - Cross Site Scripting (XSS) vulnerability (high 7.1)
- [CVE-2024-8106](https://insights.sbomify.com/CVE-2024-8106/): The Ultimate WordPress Toolkit – WP Extended <= 3.0.8 - Authenticated (Subscriber+) Sensitive Information Exposure (medium 6.5)
- [CVE-2024-9347](https://insights.sbomify.com/CVE-2024-9347/): The Ultimate WordPress Toolkit – WP Extended <= 3.0.9 - Reflected Cross-Site Scripting (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11916 and fix it if it is affected.

What it is: CVE-2024-11916 is a high-severity missing authorization vulnerability in wpextended The Ultimate WordPress Toolkit – WP Extended, published on 8 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-11916 in the wild and no public exploit code.

Affected product: wpextended The Ultimate WordPress Toolkit – WP Extended. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11916/ (Markdown: https://insights.sbomify.com/CVE-2024-11916/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11916
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11916
- OSV: https://osv.dev/vulnerability/CVE-2024-11916

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11916/
Summaries are generated and may contain mistakes; the official description above is the record.
