{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-11917 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-11917 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-11917 is a high-severity authentication bypass vulnerability in eyecix JobSearch WP Job Board, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-11917 and fix it if it is affected.\n\nWhat it is: CVE-2024-11917 is a high-severity authentication bypass vulnerability in eyecix JobSearch WP Job Board, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-11917 in the wild and no public exploit code.\n\nAffected product: eyecix JobSearch WP Job Board. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-11917/ (Markdown: https://insights.sbomify.com/CVE-2024-11917/index.md)","id":"CVE-2024-11917","markdown":"https://insights.sbomify.com/CVE-2024-11917/index.md","name":"CVE-2024-11917","record":{"aliases":["GHSA-hpf6-jp82-wrpj"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can bypass authentication to log in as connected Xing or Google users in the JobSearch WP Job Board plugin.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"The JobSearch WP Job Board plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 2.9.2. This is due to improper configurations in the 'jobsearch_xing_response_data_callback', 'set_access_tokes', and 'google_callback' functions. This makes it possible for unauthenticated attackers to log in as the first connected Xing user, or any connected Xing user if the Xing id is known. It is also possible for unauthenticated attackers to log in as the first connected Google user if the user has logged in, without subsequently logging out, in thirty days. The vulnerability was partially patched in version 2.8.4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"JobSearch WP Job Board \u003c= 2.9.2 - Authentication Bypass via Social Logins","id":"CVE-2024-11917","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"Image Alt Text \u003c= 2.0.0 - Missing Authorization to Authenticated (Subscriber+) Image Alt Text Update","id":"CVE-2024-11918"},"packages":[],"prev":{"headline":"Missing authorization in The Ultimate WordPress Toolkit – WP Extended","id":"CVE-2024-11916"},"products":["JobSearch WP Job Board"],"published":"2025-04-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["eyecix"]},"summary":"Unauthenticated attackers can bypass authentication to log in as connected Xing or Google users in the JobSearch WP Job Board plugin.","url":"https://insights.sbomify.com/CVE-2024-11917/"}