# CVE-2024-11917: JobSearch WP Job Board <= 2.9.2 - Authentication Bypass via Social Logins

> Unauthenticated attackers can bypass authentication to log in as connected Xing or Google users in the JobSearch WP Job Board plugin.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Apr 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-hpf6-jp82-wrpj

## What is CVE-2024-11917?

CVE-2024-11917 is a high-severity authentication bypass vulnerability in eyecix JobSearch WP Job Board, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The JobSearch WP Job Board plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 2.9.2. This is due to improper configurations in the 'jobsearch_xing_response_data_callback', 'set_access_tokes', and 'google_callback' functions. This makes it possible for unauthenticated attackers to log in as the first connected Xing user, or any connected Xing user if the Xing id is known. It is also possible for unauthenticated attackers to log in as the first connected Google user if the user has logged in, without subsequently logging out, in thirty days. The vulnerability was partially patched in version 2.8.4.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-11917?


## How do I fix CVE-2024-11917?

No fix has been published for CVE-2024-11917 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-11917 being exploited?

There is no known exploitation of CVE-2024-11917 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11917 and fix it if it is affected.

What it is: CVE-2024-11917 is a high-severity authentication bypass vulnerability in eyecix JobSearch WP Job Board, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-11917 in the wild and no public exploit code.

Affected product: eyecix JobSearch WP Job Board. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11917/ (Markdown: https://insights.sbomify.com/CVE-2024-11917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11917
- OSV: https://osv.dev/vulnerability/CVE-2024-11917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11917/
Summaries are generated and may contain mistakes; the official description above is the record.
