CVE-2024-11931 Insufficient Granularity of Access Control in GitLab
Developers can exfiltrate protected CI variables via CI lint due to insufficient access control granularity in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-11931?
CVE-2024-11931 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 24 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 17.0 prior to 17.6.4, from 17.7 prior to 17.7.3, and from 17.8 prior to 17.8.1. Under certain conditions, it may have been possible for users with developer role to exfiltrate protected CI variables via CI lint.
Weakness: CWE-1220
Which versions are affected by CVE-2024-11931?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 17.0.0 | 17.6.4, 17.7.3, 17.8.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-11931?
Upgrade gitlab to a fixed version for your release line: 17.6.4, 17.7.3 or 17.8.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-11931 being exploited?
There is no known exploitation of CVE-2024-11931 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-11931, GHSA-rppq-5vq8-crrp, UBUNTU-CVE-2024-11931.