{"answers":{"affected":"6 open source packages ship an affected version, including drupal/core and drupal. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-11941 in the wild and no public exploit code.","fix":"Upgrade drupal/core to a fixed version for your release line: 10.1.8 or 10.2.2.","what":"CVE-2024-11941 is a high-severity denial of service vulnerability in Drupal Drupal, published on 5 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-11941 and fix it if it is affected.\n\nWhat it is: CVE-2024-11941 is a high-severity denial of service vulnerability in Drupal Drupal, published on 5 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-11941 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/core (Packagist): affected from 10.1.0; fixed in 10.1.8\n- drupal/core (Packagist): affected from 10.1.0; fixed in 10.1.8\n- drupal/core (Packagist): affected from 10.2.0; fixed in 10.2.2\n- drupal/core (Packagist): affected from 10.2.0; fixed in 10.2.2\n- drupal/core (Packagist): affected from 8.0.0; fixed in 10.1.8, 10.2.2\n- drupal (Bitnami): affected from 8.0.0; fixed in 10.2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-11941/ (Markdown: https://insights.sbomify.com/CVE-2024-11941/index.md)","id":"CVE-2024-11941","markdown":"https://insights.sbomify.com/CVE-2024-11941/index.md","name":"CVE-2024-11941","record":{"aliases":["BIT-drupal-2024-11941","DRUPAL-CORE-2024-001","GHSA-xq54-x54m-vcpx","UBUNTU-CVE-2024-11941"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal core","requires_auth":"none","summary":"An excessive allocation flaw in Drupal core allows attackers to cause a denial of service by triggering resource exhaustion.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"drupal","vendor":"drupal"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"A vulnerability in Drupal Core allows Excessive Allocation.This issue affects Drupal Core: from 10.2.0 before 10.2.2, from 10.1.0 before 10.1.8.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Drupal core - Moderately critical - Denial of Service - SA-CORE-2024-001","id":"CVE-2024-11941","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"drupal:drupal","products":["drupal:drupal"],"type":"denial_of_service","year":"2024"},"n_packages":6,"n_references":1,"next":{"headline":"Drupal core - Moderately critical - Improper error handling - SA-CORE-2024-002","id":"CVE-2024-11942"},"packages":[{"ecosystem":"Bitnami","fixed":["10.2.4"],"introduced":["8.0.0"],"last_affected":[],"package":"drupal","purl":"pkg:bitnami/drupal","source":"BIT-drupal-2024-11941"},{"ecosystem":"Packagist","fixed":["10.1.8"],"introduced":["10.1.0"],"last_affected":[],"package":"drupal/core","purl":null,"source":"GHSA-xq54-x54m-vcpx"},{"ecosystem":"Packagist","fixed":["10.1.8"],"introduced":["10.1.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"GHSA-xq54-x54m-vcpx"},{"ecosystem":"Packagist","fixed":["10.2.2"],"introduced":["10.2.0"],"last_affected":[],"package":"drupal/core","purl":null,"source":"GHSA-xq54-x54m-vcpx"},{"ecosystem":"Packagist","fixed":["10.2.2"],"introduced":["10.2.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"GHSA-xq54-x54m-vcpx"},{"ecosystem":"Packagist","fixed":["10.1.8","10.2.2"],"introduced":["8.0.0","10.2.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"DRUPAL-CORE-2024-001"}],"prev":{"headline":"Cross-site scripting in Property Hive Mortgage Calculator","id":"CVE-2024-11940"},"products":["Drupal Core"],"published":"2024-12-05","related":[{"cvss_score":9.8,"headline":"Drupal Core SQL Injection","id":"CVE-2026-9082","kev_date_added":"2026-05-22","published":"2026-05-20"},{"cvss_score":8.8,"headline":"Drupal core Un-restricted Upload of File","id":"CVE-2020-13671","kev_date_added":"2022-01-18","published":"2020-11-20"},{"cvss_score":8.1,"headline":"Drupal Core Remote Code Execution","id":"CVE-2019-6340","kev_date_added":"2022-03-25","published":"2019-02-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-3352","kev_date_added":null,"published":"2009-09-24"},{"cvss_score":9.8,"headline":"Drupal core - Less critical - Gadget chain - SA-CORE-2024-006","id":"CVE-2024-55636","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007","id":"CVE-2024-55637","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-008","id":"CVE-2024-55638","kev_date_added":null,"published":"2024-12-09"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-05","vendors":["Drupal"]},"summary":"An excessive allocation flaw in Drupal core allows attackers to cause a denial of service by triggering resource exhaustion.","url":"https://insights.sbomify.com/CVE-2024-11941/"}