{"answers":{"affected":"4 open source packages ship an affected version, including drupal/core and drupal. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-11942 in the wild and no public exploit code.","fix":"Upgrade drupal/core to 10.2.10 or later.","what":"CVE-2024-11942 is a medium-severity vulnerability in Drupal Drupal, published on 5 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-11942 and fix it if it is affected.\n\nWhat it is: CVE-2024-11942 is a medium-severity vulnerability in Drupal Drupal, published on 5 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-11942 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/core (Packagist): affected from 10.0.0; fixed in 10.2.10\n- drupal/core (Packagist): affected from 10.0.0; fixed in 10.2.10\n- drupal/core (Packagist): affected from 10.0.0; fixed in 10.2.10\n- drupal (Bitnami): affected from 10.0.0; fixed in 10.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-11942/ (Markdown: https://insights.sbomify.com/CVE-2024-11942/index.md)","id":"CVE-2024-11942","markdown":"https://insights.sbomify.com/CVE-2024-11942/index.md","name":"CVE-2024-11942","record":{"aliases":["BIT-drupal-2024-11942","DRUPAL-CORE-2024-002","GHSA-52jr-x6h6-xj6g","UBUNTU-CVE-2024-11942"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal core","requires_auth":"none","summary":"Drupal core contains an improper error handling flaw allowing file manipulation, requiring administrators to upgrade to a patched version.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"drupal","vendor":"drupal"}],"cvss":{"score":5.9,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-390","name":"Detection of Error Condition Without Action"}],"description":"A vulnerability in Drupal Core allows File Manipulation.This issue affects Drupal Core: from 10.0.0 before 10.2.10.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Drupal core - Moderately critical - Improper error handling - SA-CORE-2024-002","id":"CVE-2024-11942","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"drupal:drupal","products":["drupal:drupal"],"type":"other","year":"2024"},"n_packages":4,"n_references":1,"next":{"headline":"워드프레스 결제 심플페이 – 우커머스 결제 플러그인 \u003c= 5.2.2 - Reflected Cross-Site Scripting via add_query_arg Function","id":"CVE-2024-11943"},"packages":[{"ecosystem":"Bitnami","fixed":["10.3.0"],"introduced":["10.0.0"],"last_affected":[],"package":"drupal","purl":"pkg:bitnami/drupal","source":"BIT-drupal-2024-11942"},{"ecosystem":"Packagist","fixed":["10.2.10"],"introduced":["10.0.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"DRUPAL-CORE-2024-002"},{"ecosystem":"Packagist","fixed":["10.2.10"],"introduced":["10.0.0"],"last_affected":[],"package":"drupal/core","purl":null,"source":"GHSA-52jr-x6h6-xj6g"},{"ecosystem":"Packagist","fixed":["10.2.10"],"introduced":["10.0.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"GHSA-52jr-x6h6-xj6g"}],"prev":{"headline":"Drupal core - Moderately critical - Denial of Service - SA-CORE-2024-001","id":"CVE-2024-11941"},"products":["Drupal Core"],"published":"2024-12-05","related":[{"cvss_score":9.8,"headline":"Drupal Core SQL Injection","id":"CVE-2026-9082","kev_date_added":"2026-05-22","published":"2026-05-20"},{"cvss_score":8.8,"headline":"Drupal core Un-restricted Upload of File","id":"CVE-2020-13671","kev_date_added":"2022-01-18","published":"2020-11-20"},{"cvss_score":8.1,"headline":"Drupal Core Remote Code Execution","id":"CVE-2019-6340","kev_date_added":"2022-03-25","published":"2019-02-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-3352","kev_date_added":null,"published":"2009-09-24"},{"cvss_score":9.8,"headline":"Drupal core - Less critical - Gadget chain - SA-CORE-2024-006","id":"CVE-2024-55636","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007","id":"CVE-2024-55637","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-008","id":"CVE-2024-55638","kev_date_added":null,"published":"2024-12-09"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-05","vendors":["Drupal"]},"summary":"Drupal core contains an improper error handling flaw allowing file manipulation, requiring administrators to upgrade to a patched version.","url":"https://insights.sbomify.com/CVE-2024-11942/"}