# CVE-2024-11942: Drupal core - Moderately critical - Improper error handling - SA-CORE-2024-002

> Drupal core contains an improper error handling flaw allowing file manipulation, requiring administrators to upgrade to a patched version.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2024
- **Updated:** 5 Dec 2024
- **Also known as:** BIT-drupal-2024-11942, DRUPAL-CORE-2024-002, GHSA-52jr-x6h6-xj6g, UBUNTU-CVE-2024-11942

## What is CVE-2024-11942?

CVE-2024-11942 is a medium-severity vulnerability in Drupal Drupal, published on 5 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in Drupal Core allows File Manipulation.This issue affects Drupal Core: from 10.0.0 before 10.2.10.

Weakness: CWE-390 (Detection of Error Condition Without Action)

## Which versions are affected by CVE-2024-11942?

4 open source packages ship an affected version, including drupal/core and drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 10.0.0 | 10.2.10 |
| `drupal/core` | Packagist | From 10.0.0 | 10.2.10 |
| `drupal/core` | Packagist | From 10.0.0 | 10.2.10 |
| `drupal` | Bitnami | From 10.0.0 | 10.3.0 |

Products: Drupal Drupal.

## How do I fix CVE-2024-11942?

Upgrade drupal/core to 10.2.10 or later.

## Is CVE-2024-11942 being exploited?

There is no known exploitation of CVE-2024-11942 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11942 and fix it if it is affected.

What it is: CVE-2024-11942 is a medium-severity vulnerability in Drupal Drupal, published on 5 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-11942 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 10.0.0; fixed in 10.2.10
- drupal/core (Packagist): affected from 10.0.0; fixed in 10.2.10
- drupal/core (Packagist): affected from 10.0.0; fixed in 10.2.10
- drupal (Bitnami): affected from 10.0.0; fixed in 10.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11942/ (Markdown: https://insights.sbomify.com/CVE-2024-11942/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11942
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11942
- OSV: https://osv.dev/vulnerability/CVE-2024-11942

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11942/
Summaries are generated and may contain mistakes; the official description above is the record.
