CVE-2024-11954 Pimcore Search Document cross site scripting

Medium 5.1 Published Updated

Attackers can inject malicious scripts into Pimcore Search Documents, potentially compromising user sessions or data.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-11954?

CVE-2024-11954 is a medium-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 28 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A vulnerability classified as problematic was found in Pimcore 11.4.2. Affected by this vulnerability is an unknown functionality of the component Search Document. The manipulation leads to basic cross site scripting. The attack can be launched remotely. The exploit has been disclosed to the public and may be used.

Weakness: CWE-80, CWE-74

Which versions are affected by CVE-2024-11954?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.

PackageAffectedFixed in
pimcore/pimcore PackagistFrom 11.4.211.5.3
pimcore/pimcore PackagistFrom 11.4.211.5.3

Products include Pimcore Pimcore.

How do I fix CVE-2024-11954?

Upgrade pimcore/pimcore to 11.5.3 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-11954 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11954 exists.

Public exploit code: 1 Exploit-DB entry.

All Pimcore Pimcore vulnerabilities

Sources

Also known as GHSA-xr3m-6gq6-22cg.

Is CVE-2024-11954 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free