{"answers":{"affected":"2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11954 exists.","fix":"Upgrade pimcore/pimcore to 11.5.3 or later.","what":"CVE-2024-11954 is a medium-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 28 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-11954 and fix it if it is affected.\n\nWhat it is: CVE-2024-11954 is a medium-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 28 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11954 exists.\n\nAffected packages and fixed versions:\n- pimcore/pimcore (Packagist): affected from 11.4.2; fixed in 11.5.3\n- pimcore/pimcore (Packagist): affected from 11.4.2; fixed in 11.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-11954/ (Markdown: https://insights.sbomify.com/CVE-2024-11954/index.md)","id":"CVE-2024-11954","markdown":"https://insights.sbomify.com/CVE-2024-11954/index.md","name":"CVE-2024-11954","record":{"aliases":["GHSA-xr3m-6gq6-22cg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Pimcore CMS","requires_auth":"high_privilege","summary":"Attackers can inject malicious scripts into Pimcore Search Documents, potentially compromising user sessions or data.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"pimcore","vendor":"pimcore"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"A vulnerability classified as problematic was found in Pimcore 11.4.2. Affected by this vulnerability is an unknown functionality of the component Search Document. The manipulation leads to basic cross site scripting. The attack can be launched remotely. The exploit has been disclosed to the public and may be used.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2025-04-14","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-04-14","kind":"exploitdb","ref":"52194","stars":null,"title":"Pimcore 11.4.2 - Stored cross site scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"Pimcore Search Document cross site scripting","id":"CVE-2024-11954","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"pimcore:pimcore","products":["pimcore:pimcore"],"type":"xss","year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"GLPI index.php redirect","id":"CVE-2024-11955"},"packages":[{"ecosystem":"Packagist","fixed":["11.5.3"],"introduced":["11.4.2"],"last_affected":[],"package":"pimcore/pimcore","purl":null,"source":"GHSA-xr3m-6gq6-22cg"},{"ecosystem":"Packagist","fixed":["11.5.3"],"introduced":["11.4.2"],"last_affected":[],"package":"pimcore/pimcore","purl":"pkg:composer/pimcore/pimcore","source":"GHSA-xr3m-6gq6-22cg"}],"prev":{"headline":"** REJECT ** DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2024-11953"},"products":["Pimcore"],"published":"2025-01-28","related":[{"cvss_score":9.8,"headline":"RCE vulnerability in Pimcore/Mail \u0026 Dynamic Text Layout","id":"CVE-2022-39365","kev_date_added":null,"published":"2022-10-27"},{"cvss_score":9.8,"headline":"Pimcore Access Control Issues","id":"CVE-2019-18981","kev_date_added":null,"published":"2019-11-15"},{"cvss_score":9.8,"headline":"Pimcore 2FA Vulnerable to Brute Forcing","id":"CVE-2019-18985","kev_date_added":null,"published":"2019-11-15"},{"cvss_score":8.8,"headline":"Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848","id":"CVE-2026-23492","kev_date_added":null,"published":"2026-01-14"},{"cvss_score":8.8,"headline":"SQL Injection in Admin Grid Filter API in Pimcore","id":"CVE-2023-47637","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.8,"headline":"Pimcore SQL Injection Vulnerability in Admin Search Find API","id":"CVE-2023-30848","kev_date_added":null,"published":"2023-04-27"},{"cvss_score":8.8,"headline":"Pimcore vulnerable to SQL Injection in Translation Export API","id":"CVE-2023-30849","kev_date_added":null,"published":"2023-04-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-28","vendors":["n/a"]},"summary":"Attackers can inject malicious scripts into Pimcore Search Documents, potentially compromising user sessions or data.","url":"https://insights.sbomify.com/CVE-2024-11954/"}