CVE-2024-11955 GLPI index.php redirect

Medium 5.3 Published Updated

Attackers can redirect users to malicious sites via the index.php redirect parameter in GLPI, requiring an upgrade to mitigate.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2024-11955?

CVE-2024-11955 is a medium-severity vulnerability in Glpi-Project Glpi, published on 25 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in GLPI up to 10.0.17. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file /index.php. The manipulation of the argument redirect leads to open redirect. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 10.0.18 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-601

Which versions are affected by CVE-2024-11955?

It affects 1 product.

Products include Glpi-Project Glpi.

How do I fix CVE-2024-11955?

No fix has been published for CVE-2024-11955 yet. Limit exposure of the affected software until one is available.

Is CVE-2024-11955 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11955 exists.

All Glpi-Project Glpi vulnerabilities

Sources

Also known as GHSA-g5fm-jq4j-c2c7, UBUNTU-CVE-2024-11955.

Is CVE-2024-11955 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free