# CVE-2024-11955: GLPI index.php redirect

> Attackers can redirect users to malicious sites via the index.php redirect parameter in GLPI, requiring an upgrade to mitigate.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Feb 2025
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-g5fm-jq4j-c2c7, UBUNTU-CVE-2024-11955

## What is CVE-2024-11955?

CVE-2024-11955 is a medium-severity vulnerability in Glpi-Project Glpi, published on 25 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in GLPI up to 10.0.17. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file /index.php. The manipulation of the argument redirect leads to open redirect. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 10.0.18 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2024-11955?

It affects 1 product.


Products: Glpi-Project Glpi.

## How do I fix CVE-2024-11955?

No fix has been published for CVE-2024-11955 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-11955 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11955 exists.

## Other vulnerabilities in Glpi-Project Glpi

- [CVE-2022-35914](https://insights.sbomify.com/CVE-2022-35914/): Teclib GLPI Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2023-42802](https://insights.sbomify.com/CVE-2023-42802/): GLPI vulnerable to unallowed PHP script execution (critical 10.0)
- [CVE-2023-28849](https://insights.sbomify.com/CVE-2023-28849/): GLPI vulnerable to SQL injection and Stored XSS via inventory agent request (critical 10.0)
- [CVE-2022-35947](https://insights.sbomify.com/CVE-2022-35947/): SQL injection in GLPI (critical 10.0)
- [CVE-2022-31056](https://insights.sbomify.com/CVE-2022-31056/): SQL injection with _actor parameter in GLPI (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11955 and fix it if it is affected.

What it is: CVE-2024-11955 is a medium-severity vulnerability in Glpi-Project Glpi, published on 25 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11955 exists.

Affected product: Glpi-Project Glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11955/ (Markdown: https://insights.sbomify.com/CVE-2024-11955/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11955
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11955
- OSV: https://osv.dev/vulnerability/CVE-2024-11955

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11955/
Summaries are generated and may contain mistakes; the official description above is the record.
