# CVE-2024-11956: Pimcore customer-data-framework list sql injection

> Remote attackers can execute arbitrary SQL commands via the customer list filter parameter, potentially accessing or modifying customer data.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2025
- **Updated:** 28 Jan 2025
- **Also known as:** GHSA-q53r-9hh9-w277

## What is CVE-2024-11956?

CVE-2024-11956 is a medium-severity SQL injection vulnerability in Pimcore Pimcore, published on 28 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A vulnerability, which was classified as critical, has been found in Pimcore customer-data-framework up to 4.2.0. Affected by this issue is some unknown functionality of the file /admin/customermanagementframework/customers/list. The manipulation of the argument filterDefinition/filter leads to sql injection. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.2.1 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-11956?

2 open source packages ship an affected version, including pimcore/customer-management-framework-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/customer-management-framework-bundle` | Packagist | All versions | 4.2.1 |
| `pimcore/customer-management-framework-bundle` | Packagist | All versions | 4.2.1 |

Products: Pimcore Pimcore.

## How do I fix CVE-2024-11956?

Upgrade pimcore/customer-management-framework-bundle to 4.2.1 or later.

## Is CVE-2024-11956 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11956 exists.

Public exploit code:

- Pimcore customer-data-framework 4.2.0 -  SQL injection (exploitdb)

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11956 and fix it if it is affected.

What it is: CVE-2024-11956 is a medium-severity SQL injection vulnerability in Pimcore Pimcore, published on 28 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11956 exists.

Affected packages and fixed versions:
- pimcore/customer-management-framework-bundle (Packagist): affected all versions; fixed in 4.2.1
- pimcore/customer-management-framework-bundle (Packagist): affected all versions; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11956/ (Markdown: https://insights.sbomify.com/CVE-2024-11956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11956
- OSV: https://osv.dev/vulnerability/CVE-2024-11956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11956/
Summaries are generated and may contain mistakes; the official description above is the record.
