# CVE-2024-11958: SQL Injection in run-llama/llama_index

> Attackers can execute arbitrary SQL and potentially remote code via the duckdb_retriever component in the llama_index library.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-339r-cjv9-x78g, PYSEC-2026-399

## What is CVE-2024-11958?

CVE-2024-11958 is a critical SQL injection vulnerability in run-llama/llama_index, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A SQL injection vulnerability exists in the `duckdb_retriever` component of the run-llama/llama_index repository, specifically in the latest version. The vulnerability arises from the construction of SQL queries without using prepared statements, allowing an attacker to inject arbitrary SQL code. This can lead to remote code execution (RCE) by installing the shellfs extension and executing malicious commands.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-11958?

3 open source packages ship an affected version, including llama-index-retrievers-duckdb-retriever. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-retrievers-duckdb-retriever` | PyPI | All versions | 0.4.0 |
| `llama-index-retrievers-duckdb-retriever` | PyPI | All versions | 0.4.0 |
| `llama-index-retrievers-duckdb-retriever` | PyPI | All versions | 0.4.0 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2024-11958?

Upgrade llama-index-retrievers-duckdb-retriever to 0.4.0 or later.

## Is CVE-2024-11958 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11958 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-23751](https://insights.sbomify.com/CVE-2024-23751/): SQL injection in llama-index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11958 and fix it if it is affected.

What it is: CVE-2024-11958 is a critical SQL injection vulnerability in run-llama/llama_index, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11958 exists.

Affected packages and fixed versions:
- llama-index-retrievers-duckdb-retriever (PyPI): affected all versions; fixed in 0.4.0
- llama-index-retrievers-duckdb-retriever (PyPI): affected all versions; fixed in 0.4.0
- llama-index-retrievers-duckdb-retriever (PyPI): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11958/ (Markdown: https://insights.sbomify.com/CVE-2024-11958/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11958
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11958
- OSV: https://osv.dev/vulnerability/CVE-2024-11958

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11958/
Summaries are generated and may contain mistakes; the official description above is the record.
