CVE-2024-11977 kk Star Ratings – Rate Post & Collect User Feedbacks <= 5.4.10 - Unauthenticated Arbitrary Shortcode Execution

High 7.3 Published Updated

Unauthenticated attackers can execute arbitrary shortcodes in the kk Star Ratings WordPress plugin due to improper validation, potentially leading to code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-11977?

CVE-2024-11977 is a high-severity code injection vulnerability in properfraction kk Star Ratings – Rate Post & Collect User Feedbacks, published on 21 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The The kk Star Ratings – Rate Post & Collect User Feedbacks plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.4.10. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. Note: This vulnerability was only partially patched in version 5.4.10.1, and fully patched in 5.4.10.2

Weakness: CWE-94

Which versions are affected by CVE-2024-11977?

How do I fix CVE-2024-11977?

No fix has been published for CVE-2024-11977 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-11977 being exploited?

There is no known exploitation of CVE-2024-11977 in the wild and no public exploit code.

Sources

Also known as GHSA-mwjr-qhm9-8w7v.

Is CVE-2024-11977 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free