{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-11977 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-11977 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-11977 is a high-severity code injection vulnerability in properfraction kk Star Ratings – Rate Post \u0026 Collect User Feedbacks, published on 21 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-11977 and fix it if it is affected.\n\nWhat it is: CVE-2024-11977 is a high-severity code injection vulnerability in properfraction kk Star Ratings – Rate Post \u0026 Collect User Feedbacks, published on 21 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-11977 in the wild and no public exploit code.\n\nAffected product: properfraction kk Star Ratings – Rate Post \u0026 Collect User Feedbacks. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-11977/ (Markdown: https://insights.sbomify.com/CVE-2024-11977/index.md)","id":"CVE-2024-11977","markdown":"https://insights.sbomify.com/CVE-2024-11977/index.md","name":"CVE-2024-11977","record":{"aliases":["GHSA-mwjr-qhm9-8w7v"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary shortcodes in the kk Star Ratings WordPress plugin due to improper validation, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"The The kk Star Ratings – Rate Post \u0026 Collect User Feedbacks plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.4.10. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.\r\nNote: This vulnerability was only partially patched in version 5.4.10.1, and fully patched in 5.4.10.2","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"kk Star Ratings – Rate Post \u0026 Collect User Feedbacks \u003c= 5.4.10 - Unauthenticated Arbitrary Shortcode Execution","id":"CVE-2024-11977","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"Interinfo DreamMaker - Arbitrary File Reading through Path Traversal","id":"CVE-2024-11978"},"packages":[],"prev":{"headline":"BuddyPress \u003c= 14.3.3 - Unauthenticated Arbitrary Shortcode Execution","id":"CVE-2024-11976"},"products":["kk Star Ratings – Rate Post \u0026 Collect User Feedbacks"],"published":"2024-12-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["properfraction"]},"summary":"Unauthenticated attackers can execute arbitrary shortcodes in the kk Star Ratings WordPress plugin due to improper validation, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2024-11977/"}