# CVE-2024-11993: Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting

> Remote attackers can execute arbitrary web script or HTML via the Dispatch name field in Liferay Portal and DXP.

- **Severity:** Medium 4.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Dec 2024
- **Updated:** 28 Mar 2025
- **Also known as:** GHSA-4hxr-28mv-q729

## What is CVE-2024-11993?

CVE-2024-11993 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 17 Dec 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Reflected cross-site scripting (XSS) vulnerability in Liferay Portal 7.4.0 through 7.4.3.38, and Liferay DXP 7.4 GA through update 38 allows remote attackers to execute arbitrary web script or HTML via Dispatch name field

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-11993?

4 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom and com.liferay.portal:release.portal.bom. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.1 | 7.4.13.u39 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.1 | 7.4.13.u39 |
| `com.liferay.portal:release.portal.bom` | Maven | From 7.1.0 | 7.4.3.39 |
| `com.liferay.portal:release.portal.bom` | Maven | From 7.1.0 | 7.4.3.39 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2024-11993?

Upgrade com.liferay.portal:release.dxp.bom to 7.4.13.u39 or later.

## Is CVE-2024-11993 being exploited?

There is no known exploitation of CVE-2024-11993 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11993 and fix it if it is affected.

What it is: CVE-2024-11993 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 17 Dec 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-11993 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.1; fixed in 7.4.13.u39
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.1; fixed in 7.4.13.u39
- com.liferay.portal:release.portal.bom (Maven): affected from 7.1.0; fixed in 7.4.3.39
- com.liferay.portal:release.portal.bom (Maven): affected from 7.1.0; fixed in 7.4.3.39

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11993/ (Markdown: https://insights.sbomify.com/CVE-2024-11993/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11993
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11993
- OSV: https://osv.dev/vulnerability/CVE-2024-11993

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11993/
Summaries are generated and may contain mistakes; the official description above is the record.
