CVE-2024-12028 Friends <= 3.2.1 - Missing Authorization

Medium 5.3 Published Updated

Unauthenticated attackers can send and accept friend requests on behalf of other sites, allowing unauthorized communication with the target WordPress site.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-12028?

CVE-2024-12028 is a medium-severity missing authorization vulnerability in akirk Friends, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Friends plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on several REST API endpoints in all versions up to, and including, 3.2.1. This makes it possible for unauthenticated attackers to send arbitrary friend requests on behalf of another website, accept the friend request for the targeted website, and then communicate with the site as an accepted friend.

Weakness: CWE-862

Which versions are affected by CVE-2024-12028?

2 open source packages ship an affected version, including wordpress and wordpress-multisite.

PackageAffectedFixed in
wordpress BitnamiAll versions3.2.2
wordpress-multisite BitnamiAll versions3.2.2

How do I fix CVE-2024-12028?

Upgrade wordpress to 3.2.2 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-12028 being exploited?

There is no known exploitation of CVE-2024-12028 in the wild and no public exploit code.

Sources

Also known as BIT-wordpress-2024-12028, BIT-wordpress-multisite-2024-12028, GHSA-fg5j-qmgq-qvmr.

Is CVE-2024-12028 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free