{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite.","exploited":"There is no known exploitation of CVE-2024-12028 in the wild and no public exploit code.","fix":"Upgrade wordpress to 3.2.2 or later.","what":"CVE-2024-12028 is a medium-severity missing authorization vulnerability in akirk Friends, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-12028 and fix it if it is affected.\n\nWhat it is: CVE-2024-12028 is a medium-severity missing authorization vulnerability in akirk Friends, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-12028 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 3.2.2\n- wordpress-multisite (Bitnami): affected all versions; fixed in 3.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-12028/ (Markdown: https://insights.sbomify.com/CVE-2024-12028/index.md)","id":"CVE-2024-12028","markdown":"https://insights.sbomify.com/CVE-2024-12028/index.md","name":"CVE-2024-12028","record":{"aliases":["BIT-wordpress-2024-12028","BIT-wordpress-multisite-2024-12028","GHSA-fg5j-qmgq-qvmr"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can send and accept friend requests on behalf of other sites, allowing unauthorized communication with the target WordPress site.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"The Friends plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on several REST API endpoints in all versions up to, and including, 3.2.1. This makes it possible for unauthenticated attackers to send arbitrary friend requests on behalf of another website, accept the friend request for the targeted website, and then communicate with the site as an accepted friend.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Friends \u003c= 3.2.1 - Missing Authorization","id":"CVE-2024-12028","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Remote Code Execution via Model Deserialization in invoke-ai/invokeai","id":"CVE-2024-12029"},"packages":[{"ecosystem":"Bitnami","fixed":["3.2.2"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2024-12028"},{"ecosystem":"Bitnami","fixed":["3.2.2"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2024-12028"}],"prev":{"headline":"Missing authorization in Message Filter for Contact Form 7","id":"CVE-2024-12027"},"products":["Friends"],"published":"2024-12-06","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["akirk"]},"summary":"Unauthenticated attackers can send and accept friend requests on behalf of other sites, allowing unauthorized communication with the target WordPress site.","url":"https://insights.sbomify.com/CVE-2024-12028/"}