# CVE-2024-12028: Friends <= 3.2.1 - Missing Authorization

> Unauthenticated attackers can send and accept friend requests on behalf of other sites, allowing unauthorized communication with the target WordPress site.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Dec 2024
- **Updated:** 8 Apr 2026
- **Also known as:** BIT-wordpress-2024-12028, BIT-wordpress-multisite-2024-12028, GHSA-fg5j-qmgq-qvmr

## What is CVE-2024-12028?

CVE-2024-12028 is a medium-severity missing authorization vulnerability in akirk Friends, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Friends plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on several REST API endpoints in all versions up to, and including, 3.2.1. This makes it possible for unauthenticated attackers to send arbitrary friend requests on behalf of another website, accept the friend request for the targeted website, and then communicate with the site as an accepted friend.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-12028?

2 open source packages ship an affected version, including wordpress and wordpress-multisite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | All versions | 3.2.2 |
| `wordpress-multisite` | Bitnami | All versions | 3.2.2 |

## How do I fix CVE-2024-12028?

Upgrade wordpress to 3.2.2 or later.

## Is CVE-2024-12028 being exploited?

There is no known exploitation of CVE-2024-12028 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-12028 and fix it if it is affected.

What it is: CVE-2024-12028 is a medium-severity missing authorization vulnerability in akirk Friends, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-12028 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected all versions; fixed in 3.2.2
- wordpress-multisite (Bitnami): affected all versions; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-12028/ (Markdown: https://insights.sbomify.com/CVE-2024-12028/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-12028
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-12028
- OSV: https://osv.dev/vulnerability/CVE-2024-12028

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-12028/
Summaries are generated and may contain mistakes; the official description above is the record.
