# CVE-2024-12029: Remote Code Execution via Model Deserialization in invoke-ai/invokeai

> Attackers can execute arbitrary code by uploading malicious model files to the InvokeAI API due to unsafe deserialization.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-mcrp-whpw-jp68, PYSEC-2025-9

## What is CVE-2024-12029?

CVE-2024-12029 is a critical unsafe deserialization vulnerability in invoke-ai/invokeai, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-12029?

3 open source packages ship an affected version, including invokeai and InvokeAI.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `invokeai` | PyPI | From 5.3.1 | 5.4.3rc1 |
| `invokeai` | PyPI | From 5.3.1 | 5.4.3rc2 |
| `InvokeAI` | PyPI | From 5.3.1 | 5.4.3rc2 |

## How do I fix CVE-2024-12029?

Upgrade invokeai to a fixed version for your release line: 5.4.3rc1 or 5.4.3rc2.

## Is CVE-2024-12029 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12029 exists.

Public exploit code:

- InvokeAI RCE (metasploit)
- This repository contains alternative payload approaches for the InvokeAI RCE vulnerability (CVE-2024-12029) when SSH key injection fails. The payloads are designed to test if pickle deserialization is actually occurring and provide alternative access methods. (github_poc): https://github.com/Lu3ky13/Alternative-Approach-Reverse-Shell-Callback-Test-InvokeAI-RCE

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-12029 and fix it if it is affected.

What it is: CVE-2024-12029 is a critical unsafe deserialization vulnerability in invoke-ai/invokeai, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12029 exists.

Affected packages and fixed versions:
- invokeai (PyPI): affected from 5.3.1; fixed in 5.4.3rc1
- invokeai (PyPI): affected from 5.3.1; fixed in 5.4.3rc2
- InvokeAI (PyPI): affected from 5.3.1; fixed in 5.4.3rc2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-12029/ (Markdown: https://insights.sbomify.com/CVE-2024-12029/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-12029
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-12029
- OSV: https://osv.dev/vulnerability/CVE-2024-12029

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-12029/
Summaries are generated and may contain mistakes; the official description above is the record.
