CVE-2024-12093 Improper Validation of Consistency within Input in GitLab

Medium 6.8 Published Updated

Attackers can bypass two-factor authentication in GitLab by exploiting improper XPath validation in SAML responses under specific conditions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-12093?

CVE-2024-12093 is a medium-severity authentication bypass vulnerability in Gitlab Gitlab, published on 22 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 11.1 before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. Improper XPath validation allows modified SAML response to bypass 2FA requirement under specialized conditions.

Weakness: CWE-1288

Which versions are affected by CVE-2024-12093?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.1.017.11.3, 18.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-12093?

Upgrade gitlab to a fixed version for your release line: 17.11.3 or 18.0.1.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2024-12093 being exploited?

There is no known exploitation of CVE-2024-12093 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-12093, GHSA-7rfw-87cg-pgwh, UBUNTU-CVE-2024-12093.

Is CVE-2024-12093 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free