CVE-2024-1211 Cross-Site Request Forgery (CSRF) in GitLab
Attackers can perform cross-site request forgery on GitLab instances using JWT OmniAuth, potentially bypassing security controls.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-1211?
CVE-2024-1211 is a medium-severity vulnerability in Gitlab Gitlab, published on 30 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.6 prior to 16.9.7, starting from 16.10 prior to 16.10.5, and starting from 16.11 prior to 16.11.2 in which cross-site request forgery may have been possible on GitLab instances configured to use JWT as an OmniAuth provider.
Weakness: CWE-352
Which versions are affected by CVE-2024-1211?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 10.6.0 | 16.9.7, 16.10.5, 16.11.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-1211?
Upgrade gitlab to a fixed version for your release line: 16.9.7, 16.10.5 or 16.11.2.
Is CVE-2024-1211 being exploited?
There is no known exploitation of CVE-2024-1211 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-1211, GHSA-5xrw-g5h5-j2r6, UBUNTU-CVE-2024-1211.