CVE-2024-12213 WP Job Board Pro < 1.2.85 - Unauthenticated Privilege Escalation via process_register

Critical 9.8 Published Updated

Unauthenticated attackers can register as administrators by supplying a role field during registration in WP Job Board Pro.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-12213?

CVE-2024-12213 is a critical vulnerability in http://apusthemes.com/ WP Job Board Pro, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The WP Job Board Pro plugin for WordPress is vulnerable to privilege escalation in all versions up to 2.3.16. This is due to the plugin allowing a user to supply the 'role' field when registering. This makes it possible for unauthenticated attackers to register as an administrator on vulnerable sites. Please note that this may have been patched sooner, however, the oldest available version for us to confirm this is patched in was 1.2.85.

Weakness: CWE-266

Which versions are affected by CVE-2024-12213?

It affects 1 product.

Products include Apusthemes Superio.

How do I fix CVE-2024-12213?

No fix has been published for CVE-2024-12213 yet. Limit exposure of the affected software until one is available.

Is CVE-2024-12213 being exploited?

There is no known exploitation of CVE-2024-12213 in the wild and no public exploit code.

Sources

Also known as GHSA-g989-9gjv-rrfg.

Is CVE-2024-12213 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free