{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-12213 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-12213 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-12213 is a critical vulnerability in http://apusthemes.com/ WP Job Board Pro, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-12213 and fix it if it is affected.\n\nWhat it is: CVE-2024-12213 is a critical vulnerability in http://apusthemes.com/ WP Job Board Pro, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-12213 in the wild and no public exploit code.\n\nAffected product: http://apusthemes.com/ WP Job Board Pro. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-12213/ (Markdown: https://insights.sbomify.com/CVE-2024-12213/index.md)","id":"CVE-2024-12213","markdown":"https://insights.sbomify.com/CVE-2024-12213/index.md","name":"CVE-2024-12213","record":{"aliases":["GHSA-g989-9gjv-rrfg"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can register as administrators by supplying a role field during registration in WP Job Board Pro.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"superio","vendor":"apusthemes"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"The WP Job Board Pro plugin for WordPress is vulnerable to privilege escalation in all versions up to 2.3.16. This is due to the plugin allowing a user to supply the 'role' field when registering. This makes it possible for unauthenticated attackers to register as an administrator on vulnerable sites. Please note that this may have been patched sooner, however, the oldest available version for us to confirm this is patched in was 1.2.85.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"WP Job Board Pro \u003c 1.2.85 - Unauthenticated Privilege Escalation via process_register","id":"CVE-2024-12213","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"WooCommerce HSS Extension for Streaming Video \u003c= 3.31 - Reflected Cross-Site Scripting via videolink Parameter","id":"CVE-2024-12214"},"packages":[],"prev":{"headline":"Horner Automation Cscape Out-of-bounds Read","id":"CVE-2024-12212"},"products":["WP Job Board Pro"],"published":"2025-02-12","related":[{"cvss_score":8.8,"headline":"Apus Framework \u003c= 2.4 - Authenticated (Subscriber+) Arbitrary Options Update in import_page_options","id":"CVE-2024-12296","kev_date_added":null,"published":"2025-02-12"},{"cvss_score":5.4,"headline":"Superio - Job Board \u003c 1.2.33 - Subscriber+ Stored Cross-Site Scripting","id":"CVE-2022-4114","kev_date_added":null,"published":"2023-01-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["http://apusthemes.com/"]},"summary":"Unauthenticated attackers can register as administrators by supplying a role field during registration in WP Job Board Pro.","url":"https://insights.sbomify.com/CVE-2024-12213/"}