# CVE-2024-12213: WP Job Board Pro < 1.2.85 - Unauthenticated Privilege Escalation via process_register

> Unauthenticated attackers can register as administrators by supplying a role field during registration in WP Job Board Pro.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Feb 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-g989-9gjv-rrfg

## What is CVE-2024-12213?

CVE-2024-12213 is a critical vulnerability in http://apusthemes.com/ WP Job Board Pro, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The WP Job Board Pro plugin for WordPress is vulnerable to privilege escalation in all versions up to 2.3.16. This is due to the plugin allowing a user to supply the 'role' field when registering. This makes it possible for unauthenticated attackers to register as an administrator on vulnerable sites. Please note that this may have been patched sooner, however, the oldest available version for us to confirm this is patched in was 1.2.85.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2024-12213?

It affects 1 product.


Products: Apusthemes Superio.

## How do I fix CVE-2024-12213?

No fix has been published for CVE-2024-12213 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-12213 being exploited?

There is no known exploitation of CVE-2024-12213 in the wild and no public exploit code.

## Other vulnerabilities in http://apusthemes.com/ WP Job Board Pro

- [CVE-2024-12296](https://insights.sbomify.com/CVE-2024-12296/): Apus Framework <= 2.4 - Authenticated (Subscriber+) Arbitrary Options Update in import_page_options (high 8.8)
- [CVE-2022-4114](https://insights.sbomify.com/CVE-2022-4114/): Superio - Job Board < 1.2.33 - Subscriber+ Stored Cross-Site Scripting (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-12213 and fix it if it is affected.

What it is: CVE-2024-12213 is a critical vulnerability in http://apusthemes.com/ WP Job Board Pro, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-12213 in the wild and no public exploit code.

Affected product: http://apusthemes.com/ WP Job Board Pro. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-12213/ (Markdown: https://insights.sbomify.com/CVE-2024-12213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-12213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-12213
- OSV: https://osv.dev/vulnerability/CVE-2024-12213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-12213/
Summaries are generated and may contain mistakes; the official description above is the record.
