# CVE-2024-12289: Boundary Controller Incorrectly Handles HTTP Requests On Initialization Which May Lead to a Denial of Service

> Attackers can cause premature termination of the Boundary server by sending HTTP requests during its brief initialization phase.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2024
- **Updated:** 13 Dec 2024
- **Also known as:** GHSA-xx83-cxmq-x89m, GO-2024-3335

## What is CVE-2024-12289?

CVE-2024-12289 is a medium-severity denial of service vulnerability in HashiCorp Boundary, published on 12 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Boundary Community Edition and Boundary Enterprise (“Boundary”) incorrectly handle HTTP requests during the initialization of the Boundary controller, which may cause the Boundary server to terminate prematurely. Boundary is only vulnerable to this flaw during the initialization of the Boundary controller, which on average is measured in milliseconds during the Boundary startup process.

This vulnerability, CVE-2024-12289, is fixed in Boundary Community Edition and Boundary Enterprise 0.16.4, 0.17.3, 0.18.2.

Weakness: CWE-665 (Improper Initialization), CWE-460 (Improper Cleanup on Thrown Exception)

## Which versions are affected by CVE-2024-12289?

3 open source packages ship an affected version, including github.com/hashicorp/boundary. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/boundary` | Go | All versions | 0.18.2 |
| `github.com/hashicorp/boundary` | Go | All versions | 0.18.2 |
| `github.com/hashicorp/boundary` | Go | All versions | 0.18.2 |

Products: Hashicorp Boundary.

## How do I fix CVE-2024-12289?

Upgrade github.com/hashicorp/boundary to 0.18.2 or later.

## Is CVE-2024-12289 being exploited?

There is no known exploitation of CVE-2024-12289 in the wild and no public exploit code.

## Other vulnerabilities in HashiCorp Boundary

- [CVE-2022-36130](https://insights.sbomify.com/CVE-2022-36130/): Privilege escalation in n/a (critical 9.9)
- [CVE-2024-1052](https://insights.sbomify.com/CVE-2024-1052/): Boundary Vulnerable to Session Hijacking Through TLS Certificate Tampering (high 8.0)
- [CVE-2022-36182](https://insights.sbomify.com/CVE-2022-36182/): Hashicorp Boundary vulnerable to clickjacking (medium 6.1)
- [CVE-2023-0690](https://insights.sbomify.com/CVE-2023-0690/): Boundary Workers Store Rotated Credentials in Plaintext Even When a Key Management Service Configured (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-12289 and fix it if it is affected.

What it is: CVE-2024-12289 is a medium-severity denial of service vulnerability in HashiCorp Boundary, published on 12 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-12289 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/boundary (Go): affected all versions; fixed in 0.18.2
- github.com/hashicorp/boundary (Go): affected all versions; fixed in 0.18.2
- github.com/hashicorp/boundary (Go): affected all versions; fixed in 0.18.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-12289/ (Markdown: https://insights.sbomify.com/CVE-2024-12289/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-12289
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-12289
- OSV: https://osv.dev/vulnerability/CVE-2024-12289

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-12289/
Summaries are generated and may contain mistakes; the official description above is the record.
