CVE-2024-12292 Insertion of Sensitive Information into Log File in GitLab
Attackers with log access can read sensitive data from GraphQL mutations, requiring GitLab administrators to upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-12292?
CVE-2024-12292 is a medium-severity vulnerability in Gitlab Gitlab, published on 12 Dec 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
An issue was discovered in GitLab CE/EE affecting all versions starting from 11.0 prior to 17.4.6, starting from 17.5 prior to 17.5.4, and starting from 17.6 prior to 17.6.2, where sensitive information passed in GraphQL mutations may have been retained in GraphQL logs.
Weakness: CWE-532
Which versions are affected by CVE-2024-12292?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 11.0.0 | 17.4.6, 17.5.4, 17.6.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-12292?
Upgrade gitlab to a fixed version for your release line: 17.4.6, 17.5.4 or 17.6.2.
Is CVE-2024-12292 being exploited?
There is no known exploitation of CVE-2024-12292 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-12292, GHSA-86fp-jr93-hvv2, UBUNTU-CVE-2024-12292.