{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-12296 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-12296 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-12296 is a high-severity missing authorization vulnerability in ApusTheme Apus Framework, published on 12 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-12296 and fix it if it is affected.\n\nWhat it is: CVE-2024-12296 is a high-severity missing authorization vulnerability in ApusTheme Apus Framework, published on 12 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-12296 in the wild and no public exploit code.\n\nAffected product: ApusTheme Apus Framework. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-12296/ (Markdown: https://insights.sbomify.com/CVE-2024-12296/index.md)","id":"CVE-2024-12296","markdown":"https://insights.sbomify.com/CVE-2024-12296/index.md","name":"CVE-2024-12296","record":{"aliases":["GHSA-4vxh-jq3c-5rhw"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated subscribers can update arbitrary site options to escalate privileges to administrator due to missing capability checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"superio","vendor":"apusthemes"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"The Apus Framework plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check on the 'import_page_options' function in all versions up to, and including, 2.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site. NOTE: This vulnerability was partially fixed in version 2.4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Apus Framework \u003c= 2.4 - Authenticated (Subscriber+) Arbitrary Options Update in import_page_options","id":"CVE-2024-12296","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"Frontend Authorization Logic Disclosure Vulnerability","id":"CVE-2024-12297"},"packages":[],"prev":{"headline":"Privilege escalation in BoomBox Theme Extensions","id":"CVE-2024-12295"},"products":["Apus Framework"],"published":"2025-02-12","related":[{"cvss_score":9.8,"headline":"WP Job Board Pro \u003c 1.2.85 - Unauthenticated Privilege Escalation via process_register","id":"CVE-2024-12213","kev_date_added":null,"published":"2025-02-12"},{"cvss_score":5.4,"headline":"Superio - Job Board \u003c 1.2.33 - Subscriber+ Stored Cross-Site Scripting","id":"CVE-2022-4114","kev_date_added":null,"published":"2023-01-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["ApusTheme"]},"summary":"Authenticated subscribers can update arbitrary site options to escalate privileges to administrator due to missing capability checks.","url":"https://insights.sbomify.com/CVE-2024-12296/"}