CVE-2024-12303 Incorrect Privilege Assignment in GitLab

Medium 6.7 Published Updated

Authenticated users with specific roles can delete confidential issues by inviting users with a specific role, requiring an upgrade to GitLab.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-12303?

CVE-2024-12303 is a medium-severity vulnerability in Gitlab Gitlab, published on 13 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 17.7 before 18.0.6, 18.1 before 18.1.4, and 18.2 before 18.2.2 that under certain conditions could have allowed authenticated users with specific roles and permissions to delete issues including confidential ones by inviting users with a specific role.

Weakness: CWE-266

Which versions are affected by CVE-2024-12303?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.7.018.0.6, 18.1.4, 18.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-12303?

Upgrade gitlab to a fixed version for your release line: 18.0.6, 18.1.4 or 18.2.2.

Is CVE-2024-12303 being exploited?

There is no known exploitation of CVE-2024-12303 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-12303, GHSA-cxxf-6583-j227, MINI-6622-f7m7-m4v7, MINI-fp2h-jjmh-wg8f, MINI-rv5p-775m-fg99, UBUNTU-CVE-2024-12303.

Is CVE-2024-12303 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free