# CVE-2024-12303: Incorrect Privilege Assignment in GitLab

> Authenticated users with specific roles can delete confidential issues by inviting users with a specific role, requiring an upgrade to GitLab.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2025
- **Updated:** 13 Aug 2025
- **Also known as:** BIT-gitlab-2024-12303, GHSA-cxxf-6583-j227, MINI-6622-f7m7-m4v7, MINI-fp2h-jjmh-wg8f, MINI-rv5p-775m-fg99, UBUNTU-CVE-2024-12303

## What is CVE-2024-12303?

CVE-2024-12303 is a medium-severity vulnerability in Gitlab Gitlab, published on 13 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 17.7 before 18.0.6, 18.1 before 18.1.4, and 18.2 before 18.2.2 that under certain conditions could have allowed authenticated users with specific roles and permissions to delete issues including confidential ones by inviting users with a specific role.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2024-12303?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 17.7.0 | 18.0.6, 18.1.4, 18.2.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2024-12303?

Upgrade gitlab to a fixed version for your release line: 18.0.6, 18.1.4 or 18.2.2.

## Is CVE-2024-12303 being exploited?

There is no known exploitation of CVE-2024-12303 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-12303 and fix it if it is affected.

What it is: CVE-2024-12303 is a medium-severity vulnerability in Gitlab Gitlab, published on 13 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-12303 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 17.7.0; fixed in 18.0.6, 18.1.4, 18.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-12303/ (Markdown: https://insights.sbomify.com/CVE-2024-12303/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-12303
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-12303
- OSV: https://osv.dev/vulnerability/CVE-2024-12303

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-12303/
Summaries are generated and may contain mistakes; the official description above is the record.
