# CVE-2024-12368: Missing authorization in Odoo Community

> An internal user can improperly export OAuth tokens of other users in Odoo, potentially leading to account takeover.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2025
- **Updated:** 25 Feb 2025
- **Also known as:** BIT-odoo-2024-12368, DEBIAN-CVE-2024-12368, GHSA-j4gm-mr6g-474q, UBUNTU-CVE-2024-12368

## What is CVE-2024-12368?

CVE-2024-12368 is a high-severity missing authorization vulnerability in Odoo Odoo, published on 25 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper access control in the auth_oauth module of Odoo Community 15.0 and Odoo Enterprise 15.0 allows an internal user to export the OAuth tokens of other users.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-12368?

1 open source package ship an affected version, including odoo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `odoo` | Bitnami | From 15.0.0 | 15.0.20240510 |

Products: Odoo Odoo.

## How do I fix CVE-2024-12368?

Upgrade odoo to 15.0.20240510 or later.

## Is CVE-2024-12368 being exploited?

There is no known exploitation of CVE-2024-12368 in the wild and no public exploit code.

## Other vulnerabilities in Odoo Odoo

- [CVE-2020-29396](https://insights.sbomify.com/CVE-2020-29396/): Code injection in Odoo Community (critical 9.9)
- [CVE-2018-14885](https://insights.sbomify.com/CVE-2018-14885/): Auth bypass in n/a (critical 9.8)
- [CVE-2017-10804](https://insights.sbomify.com/CVE-2017-10804/): Auth bypass in n/a (critical 9.8)
- [CVE-2018-14860](https://insights.sbomify.com/CVE-2018-14860/): Code injection in n/a (critical 9.1)
- [CVE-2017-10805](https://insights.sbomify.com/CVE-2017-10805/): Auth bypass in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-12368 and fix it if it is affected.

What it is: CVE-2024-12368 is a high-severity missing authorization vulnerability in Odoo Odoo, published on 25 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-12368 in the wild and no public exploit code.

Affected packages and fixed versions:
- odoo (Bitnami): affected from 15.0.0; fixed in 15.0.20240510

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-12368/ (Markdown: https://insights.sbomify.com/CVE-2024-12368/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-12368
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-12368
- OSV: https://osv.dev/vulnerability/CVE-2024-12368

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-12368/
Summaries are generated and may contain mistakes; the official description above is the record.
