CVE-2024-12393 Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2024-003
An XSS vulnerability in Drupal core allows attackers to inject malicious scripts, potentially leading to code execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-12393?
CVE-2024-12393 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 9 Dec 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Drupal Core allows Cross-Site Scripting (XSS).This issue affects Drupal Core: from 8.8.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.
Weakness: CWE-79
Which versions are affected by CVE-2024-12393?
20 open source packages ship an affected version, including drupal/core, drupal and drupal/core-recommended. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 10.3.0 | 10.3.9 |
drupal/core Packagist | From 10.3.0 | 10.3.9 |
drupal/core Packagist | From 11.0.0 | 11.0.8 |
drupal/core Packagist | From 11.0.0 | 11.0.8 |
drupal/core Packagist | From 8.8.0 | 10.2.11, 10.3.9, 11.0.8 |
drupal/core Packagist | From 8.8.0 | 10.2.11 |
14 more packages
drupal/core Packagist | From 8.8.0 | 10.2.11 |
drupal Bitnami | From 8.8.0 | 10.3.9, 11.0.8 |
drupal/core-recommended Packagist | From 10.3.0 | 10.3.9 |
drupal/core-recommended Packagist | From 10.3.0 | 10.3.9 |
drupal/core-recommended Packagist | From 11.0.0 | 11.0.8 |
drupal/core-recommended Packagist | From 11.0.0 | 11.0.8 |
drupal/core-recommended Packagist | From 8.8.0 | 10.2.11 |
drupal/core-recommended Packagist | From 8.8.0 | 10.2.11 |
drupal/drupal Packagist | From 10.3.0 | 10.3.9 |
drupal/drupal Packagist | From 10.3.0 | 10.3.9 |
drupal/drupal Packagist | From 11.0.0 | 11.0.8 |
drupal/drupal Packagist | From 11.0.0 | 11.0.8 |
drupal/drupal Packagist | From 8.8.0 | 10.2.11 |
drupal/drupal Packagist | From 8.8.0 | 10.2.11 |
Products include Drupal Drupal.
How do I fix CVE-2024-12393?
Upgrade drupal/core to a fixed version for your release line: 10.3.9, 11.0.8 or 10.2.11.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-12393 being exploited?
There is no known exploitation of CVE-2024-12393 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as BIT-drupal-2024-12393, DRUPAL-CORE-2024-003, GHSA-8mvq-8h2v-j9vf, UBUNTU-CVE-2024-12393.