CVE-2024-12421 Code injection in Coupon Affiliates – Affiliate Plugin for WooCommerce

Medium 6.5 Published Updated

Unauthenticated attackers can execute arbitrary shortcodes and inject scripts via reflected XSS in the Coupon Affiliates WooCommerce plugin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-12421?

CVE-2024-12421 is a medium-severity code injection vulnerability in elliotvs Coupon Affiliates – Affiliate Plugin for WooCommerce, published on 13 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The The Coupon Affiliates – Affiliate Plugin for WooCommerce plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.16.7.1. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. This functionality is also vulnerable to Reflected Cross-Site Scripting. The Cross-Site Scripting was patched in version 5.16.7.1, while the arbitrary shortcode execution was patched in 5.16.7.2.

Weakness: CWE-94

Which versions are affected by CVE-2024-12421?

How do I fix CVE-2024-12421?

No fix has been published for CVE-2024-12421 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-12421 being exploited?

There is no known exploitation of CVE-2024-12421 in the wild and no public exploit code.

Sources

Also known as GHSA-83mc-2h64-8h9q.

Is CVE-2024-12421 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free