CVE-2024-1247 Concrete CMS version 9 before 9.2.5 vulnerable to stored XSS via the Role Name field

Low 2.0 Published Updated

A rogue administrator can inject malicious scripts into the Role Name field, leading to stored XSS execution for other users.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-1247?

CVE-2024-1247 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 9 Feb 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Concrete CMS version 9 before 9.2.5 is vulnerable to  stored XSS via the Role Name field since there is insufficient validation of administrator provided data for that field. A rogue administrator could inject malicious code into the Role Name field which might be executed when users visit the affected page. The Concrete CMS Security team scored this 2 with CVSS v3 vector AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator . Concrete versions below 9 do not include group types so they are not affected by this vulnerability.

Weakness: CWE-79, CWE-20

Which versions are affected by CVE-2024-1247?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistFrom 9.0.0RC19.2.5
concrete5/concrete5 PackagistFrom 9.0.0RC19.2.5

Products include Concretecms Concrete Cms.

How do I fix CVE-2024-1247?

Upgrade concrete5/concrete5 to 9.2.5 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-1247 being exploited?

There is no known exploitation of CVE-2024-1247 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-q25h-jch8-gfrp.

Is CVE-2024-1247 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free