{"answers":{"affected":"2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-1247 in the wild and no public exploit code.","fix":"Upgrade concrete5/concrete5 to 9.2.5 or later.","what":"CVE-2024-1247 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 9 Feb 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-1247 and fix it if it is affected.\n\nWhat it is: CVE-2024-1247 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 9 Feb 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-1247 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- concrete5/concrete5 (Packagist): affected from 9.0.0RC1; fixed in 9.2.5\n- concrete5/concrete5 (Packagist): affected from 9.0.0RC1; fixed in 9.2.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-1247/ (Markdown: https://insights.sbomify.com/CVE-2024-1247/index.md)","id":"CVE-2024-1247","markdown":"https://insights.sbomify.com/CVE-2024-1247/index.md","name":"CVE-2024-1247","record":{"aliases":["GHSA-q25h-jch8-gfrp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Concrete CMS","requires_auth":"high_privilege","summary":"A rogue administrator can inject malicious scripts into the Role Name field, leading to stored XSS execution for other users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"ConcreteCMS","cpe":[{"product":"concrete_cms","vendor":"concretecms"}],"cvss":{"score":2,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Concrete CMS version 9 before 9.2.5 is vulnerable to  stored XSS via the Role Name field since there is insufficient validation of administrator provided data for that field. A rogue administrator could inject malicious code into the Role Name field which might be executed when users visit the affected page. The Concrete CMS Security team scored this 2 with CVSS v3 vector  AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator . Concrete versions below 9 do not include group types so they are not affected by this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2025-01-15","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-01-15T11:13:14Z","kind":"github_poc","ref":"https://github.com/Nxploited/CVE-2024-1247-PoC","stars":0,"title":"Post Saint \u003c= 1.3.1 plugin for WordPress Arbitrary File Upload "}],"tier":"poc_unverified"},"has_fix":true,"headline":"Concrete CMS version 9 before 9.2.5 vulnerable to stored XSS via the Role Name field","id":"CVE-2024-1247","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"concretecms:concrete_cms","products":["concretecms:concrete_cms"],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Role Overwriting via Silent JIT Provisioning in Multiple WSO2 Products Enables Privilege Escalation","id":"CVE-2024-1248"},"packages":[{"ecosystem":"Packagist","fixed":["9.2.5"],"introduced":["9.0.0RC1"],"last_affected":[],"package":"concrete5/concrete5","purl":null,"source":"GHSA-q25h-jch8-gfrp"},{"ecosystem":"Packagist","fixed":["9.2.5"],"introduced":["9.0.0RC1"],"last_affected":[],"package":"concrete5/concrete5","purl":"pkg:composer/concrete5/concrete5","source":"GHSA-q25h-jch8-gfrp"}],"prev":{"headline":"Concrete CMS in version 9 before 9.2.5 is vulnerable to reflected XSS via the Image URL Import Feature","id":"CVE-2024-1246"},"products":["Concrete CMS"],"published":"2024-02-09","related":[{"cvss_score":9.8,"headline":"Concrete CMS allows unauthorized access because directories can be created with insecure permissions","id":"CVE-2023-48648","kev_date_added":null,"published":"2023-11-17"},{"cvss_score":9.8,"headline":"Code injection in concrete CMS","id":"CVE-2022-21829","kev_date_added":null,"published":"2022-06-24"},{"cvss_score":9.8,"headline":"Server-Side Request Forgery vulnerability in concrete5","id":"CVE-2021-22958","kev_date_added":null,"published":"2021-10-07"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2021-40098","kev_date_added":null,"published":"2021-09-27"},{"cvss_score":9.4,"headline":"Concrete CMS Vulnerable to Relative Path Traversal","id":"CVE-2026-8134","kev_date_added":null,"published":"2026-05-21"},{"cvss_score":9.1,"headline":"Path traversal in Concrete CMS","id":"CVE-2022-30117","kev_date_added":null,"published":"2022-06-24"},{"cvss_score":9.1,"headline":"Deserialization in n/a","id":"CVE-2021-40102","kev_date_added":null,"published":"2021-09-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["Concrete CMS"]},"summary":"A rogue administrator can inject malicious scripts into the Role Name field, leading to stored XSS execution for other users.","url":"https://insights.sbomify.com/CVE-2024-1247/"}