# CVE-2024-12539: Elasticsearch Incorrect Authorization

> Attackers can bypass Document Level Security to read unauthorized documents in Elasticsearch, requiring immediate patching for data confidentiality.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2024
- **Updated:** 17 Dec 2024
- **Also known as:** BIT-elasticsearch-2024-12539, GHSA-5mpw-4546-2wcr, MINI-hhxr-g58x-7cc2, MINI-xmff-3qpr-rh4g, UBUNTU-CVE-2024-12539

## What is CVE-2024-12539?

CVE-2024-12539 is a medium-severity missing authorization vulnerability in Elastic Elasticsearch, published on 17 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered where improper authorization controls affected certain queries that could allow a malicious actor to circumvent Document Level Security in Elasticsearch and get access to documents that their roles would normally not allow.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-12539?

3 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | From 8.16.0 | 8.16.2 |
| `org.elasticsearch:elasticsearch` | Maven | From 8.16.0 | 8.16.2 |
| `elasticsearch` | Bitnami | From 8.16.0 | 8.17.0 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2024-12539?

Upgrade org.elasticsearch:elasticsearch to 8.16.2 or later.

## Is CVE-2024-12539 being exploited?

There is no known exploitation of CVE-2024-12539 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-12539 and fix it if it is affected.

What it is: CVE-2024-12539 is a medium-severity missing authorization vulnerability in Elastic Elasticsearch, published on 17 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-12539 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected from 8.16.0; fixed in 8.16.2
- org.elasticsearch:elasticsearch (Maven): affected from 8.16.0; fixed in 8.16.2
- elasticsearch (Bitnami): affected from 8.16.0; fixed in 8.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-12539/ (Markdown: https://insights.sbomify.com/CVE-2024-12539/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-12539
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-12539
- OSV: https://osv.dev/vulnerability/CVE-2024-12539

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-12539/
Summaries are generated and may contain mistakes; the official description above is the record.
