# CVE-2024-12615: Passwords Manager <= 1.4.8 - Authenticated (Subscriber+) SQL Injection

> Authenticated attackers with Subscriber access can exploit SQL injection to extract sensitive database information from the Passwords Manager plugin.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Jan 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-9gqj-gcg6-fqjj

## What is CVE-2024-12615?

CVE-2024-12615 is a medium-severity SQL injection vulnerability in coder426 Passwords Manager, published on 16 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Passwords Manager plugin for WordPress is vulnerable to SQL Injection via the $wpdb->prefix value in several AJAX actions in all versions up to, and including, 1.4.8 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query.  This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-12615?

It affects 1 product.


Products: Hirewebxperts Passwords Manager.

## How do I fix CVE-2024-12615?

No fix has been published for CVE-2024-12615 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-12615 being exploited?

There is no known exploitation of CVE-2024-12615 in the wild and no public exploit code.

## Other vulnerabilities in coder426 Passwords Manager

- [CVE-2024-12613](https://insights.sbomify.com/CVE-2024-12613/): Passwords Manager <= 1.4.8 - Unauthenticated SQL Injection (high 7.5)
- [CVE-2024-12614](https://insights.sbomify.com/CVE-2024-12614/): Passwords Manager <= 1.4.8 - Missing Authorization to Authenticated (Subscriber+) Add Password + Update Encryption Key (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-12615 and fix it if it is affected.

What it is: CVE-2024-12615 is a medium-severity SQL injection vulnerability in coder426 Passwords Manager, published on 16 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-12615 in the wild and no public exploit code.

Affected product: coder426 Passwords Manager. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-12615/ (Markdown: https://insights.sbomify.com/CVE-2024-12615/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-12615
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-12615
- OSV: https://osv.dev/vulnerability/CVE-2024-12615

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-12615/
Summaries are generated and may contain mistakes; the official description above is the record.
