CVE-2024-12667 InvoicePlane view session expiration

Medium 6.3 Published Updated

Remote attackers can force session expiration in InvoicePlane, causing denial of service for legitimate users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-12667?

CVE-2024-12667 is a medium-severity vulnerability in InvoicePlane, published on 16 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability was found in InvoicePlane up to 1.6.1 and classified as problematic. Affected by this issue is some unknown functionality of the file /invoices/view. The manipulation leads to session expiration. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.6.2-beta-1 is able to address this issue. It is recommended to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Weakness: CWE-613

Which versions are affected by CVE-2024-12667?

It affects 1 product.

Products include Invoiceplane Invoiceplane.

How do I fix CVE-2024-12667?

No fix has been published for CVE-2024-12667 yet. Limit exposure of the affected software until one is available.

Is CVE-2024-12667 being exploited?

There is no known exploitation of CVE-2024-12667 in the wild and no public exploit code.

Sources

Also known as GHSA-xxvf-6jpw-pp5x.

Is CVE-2024-12667 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free