CVE-2024-12678 Nomad Allocations Vulnerable To Privilege Escalation Within A Namespace Using Unredacted Workload Identity Tokens

Medium 6.5 Published Updated

Attackers can escalate privileges within a namespace using unredacted workload identity tokens in HashiCorp Nomad allocations.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-12678?

CVE-2024-12678 is a medium-severity vulnerability in HashiCorp Nomad, published on 20 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Nomad Community and Nomad Enterprise ("Nomad") allocations are vulnerable to privilege escalation within a namespace through unredacted workload identity tokens. This vulnerability, identified as CVE-2024-12678, is fixed in Nomad Community Edition 1.9.4 and Nomad Enterprise 1.9.4, 1.8.8, and 1.7.16.

Weakness: CWE-266

Which versions are affected by CVE-2024-12678?

3 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.

PackageAffectedFixed in
github.com/hashicorp/nomad GoAll versions1.9.4
github.com/hashicorp/nomad GoAll versions1.9.4
github.com/hashicorp/nomad GoAll versions1.9.4

Products include Hashicorp Nomad.

How do I fix CVE-2024-12678?

Upgrade github.com/hashicorp/nomad to 1.9.4 or later.

Is CVE-2024-12678 being exploited?

There is no known exploitation of CVE-2024-12678 in the wild and no public exploit code.

Sources

Also known as GHSA-hr68-hvgv-xxqf, GO-2024-3354, UBUNTU-CVE-2024-12678.

Is CVE-2024-12678 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free