# CVE-2024-12678: Nomad Allocations Vulnerable To Privilege Escalation Within A Namespace Using Unredacted Workload Identity Tokens

> Attackers can escalate privileges within a namespace using unredacted workload identity tokens in HashiCorp Nomad allocations.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Dec 2024
- **Updated:** 20 Dec 2024
- **Also known as:** GHSA-hr68-hvgv-xxqf, GO-2024-3354, UBUNTU-CVE-2024-12678

## What is CVE-2024-12678?

CVE-2024-12678 is a medium-severity vulnerability in HashiCorp Nomad, published on 20 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nomad Community and Nomad Enterprise ("Nomad") allocations are vulnerable to privilege escalation within a namespace through unredacted workload identity tokens. This vulnerability, identified as CVE-2024-12678, is fixed in Nomad Community Edition 1.9.4 and Nomad Enterprise 1.9.4, 1.8.8, and 1.7.16.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2024-12678?

3 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/nomad` | Go | All versions | 1.9.4 |
| `github.com/hashicorp/nomad` | Go | All versions | 1.9.4 |
| `github.com/hashicorp/nomad` | Go | All versions | 1.9.4 |

Products: Hashicorp Nomad.

## How do I fix CVE-2024-12678?

Upgrade github.com/hashicorp/nomad to 1.9.4 or later.

## Is CVE-2024-12678 being exploited?

There is no known exploitation of CVE-2024-12678 in the wild and no public exploit code.

## Other vulnerabilities in HashiCorp Nomad

- [CVE-2023-1782](https://insights.sbomify.com/CVE-2023-1782/): Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation (critical 10.0)
- [CVE-2022-30324](https://insights.sbomify.com/CVE-2022-30324/): Privilege escalation in Hashicorp Nomad (critical 9.8)
- [CVE-2020-7956](https://insights.sbomify.com/CVE-2020-7956/): Improper Certificate Validation in HashiCorp Nomad (critical 9.8)
- [CVE-2019-12618](https://insights.sbomify.com/CVE-2019-12618/): Hashicorp Nomad Access Control Issues (critical 9.8)
- [CVE-2020-27195](https://insights.sbomify.com/CVE-2020-27195/): Use After Free in HashiCorp Nomad (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-12678 and fix it if it is affected.

What it is: CVE-2024-12678 is a medium-severity vulnerability in HashiCorp Nomad, published on 20 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-12678 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 1.9.4
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 1.9.4
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 1.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-12678/ (Markdown: https://insights.sbomify.com/CVE-2024-12678/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-12678
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-12678
- OSV: https://osv.dev/vulnerability/CVE-2024-12678

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-12678/
Summaries are generated and may contain mistakes; the official description above is the record.
