# CVE-2024-12704: Denial of Service (DoS) in run-llama/llama_index

> An attacker can cause a denial of service in the llama_index library by triggering an infinite loop through improper exception handling in streaming methods.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-j3wr-m6xh-64hg, PYSEC-2025-244, PYSEC-2026-1563

## What is CVE-2024-12704?

CVE-2024-12704 is a high-severity denial of service vulnerability in run-llama/llama_index, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in the LangChainLLM class of the run-llama/llama_index repository, version v0.12.5, allows for a Denial of Service (DoS) attack. The stream_complete method executes the llm using a thread and retrieves the result via the get_response_gen method of the StreamingGeneratorCallbackHandler class. If the thread terminates abnormally before the _llm.predict is executed, there is no exception handling for this case, leading to an infinite loop in the get_response_gen function. This can be triggered by providing an input of an incorrect type, causing the thread to terminate and the process to continue running indefinitely.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2024-12704?

4 open source packages ship an affected version, including llama-index-core and llama-index. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-core` | PyPI | All versions | 0.12.6 |
| `llama-index-core` | PyPI | All versions | 0.12.6 |
| `llama-index-core` | PyPI | All versions | 0.12.6 |
| `llama-index` | PyPI | All versions to 0.12.5 | None |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2024-12704?

Upgrade llama-index-core to 0.12.6 or later.

## Is CVE-2024-12704 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12704 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-12704 and fix it if it is affected.

What it is: CVE-2024-12704 is a high-severity denial of service vulnerability in run-llama/llama_index, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12704 exists.

Affected packages and fixed versions:
- llama-index-core (PyPI): affected all versions; fixed in 0.12.6
- llama-index-core (PyPI): affected all versions; fixed in 0.12.6
- llama-index-core (PyPI): affected all versions; fixed in 0.12.6
- llama-index (PyPI): affected all versions up to 0.12.5; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-12704/ (Markdown: https://insights.sbomify.com/CVE-2024-12704/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-12704
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-12704
- OSV: https://osv.dev/vulnerability/CVE-2024-12704

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-12704/
Summaries are generated and may contain mistakes; the official description above is the record.
