{"answers":{"affected":"3 open source packages ship an affected version, including libpython, python and python-min.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12718 exists.","fix":"Upgrade libpython to a fixed version for your release line: 3.9.23, 3.10.18, 3.11.13 or 3.12.11.","what":"CVE-2024-12718 is a medium-severity path traversal vulnerability in CPython, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-12718 and fix it if it is affected.\n\nWhat it is: CVE-2024-12718 is a medium-severity path traversal vulnerability in CPython, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12718 exists.\n\nAffected packages and fixed versions:\n- libpython (Bitnami): affected all versions; fixed in 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4\n- python (Bitnami): affected all versions; fixed in 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4\n- python-min (Bitnami): affected all versions; fixed in 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-12718/ (Markdown: https://insights.sbomify.com/CVE-2024-12718/index.md)","id":"CVE-2024-12718","markdown":"https://insights.sbomify.com/CVE-2024-12718/index.md","name":"CVE-2024-12718","record":{"aliases":["ALPINE-CVE-2024-12718","AZL-62258","BELL-CVE-2024-12718","BIT-libpython-2024-12718","BIT-python-2024-12718","BIT-python-min-2024-12718","CLEANSTART-2026-IG20308","DEBIAN-CVE-2024-12718","ECHO-83e1-a1f5-89ba","GHSA-2pg8-h2j6-28xm","MINI-6858-92ff-49v8","MINI-gmh8-x358-75xc","MINI-gvgf-hhg6-7pmh","MINI-vc96-27jr-q872","PSF-2025-5","UBUNTU-CVE-2024-12718"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Python tarfile module","requires_auth":"none","summary":"Attackers can modify file metadata or permissions outside the extraction directory when using specific tarfile extraction filters.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PSF","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Allows modifying some file metadata (e.g. last modified) with filter=\"data\" or file permissions (chmod) with filter=\"tar\" of files outside the extraction directory.\nYou are affected by this vulnerability if using the tarfile module to extract untrusted tar archives using TarFile.extractall() or TarFile.extract() using the filter= parameter with a value of \"data\" or \"tar\". See the tarfile  extraction filters documentation https://docs.python.org/3/library/tarfile.html#tarfile-extraction-filter  for more information. Only Python versions 3.12 or later are affected by these vulnerabilities, earlier versions don't include the extraction filter feature.\n\nNote that for Python 3.14 or later the default value of filter= changed from \"no filtering\" to `\"data\", so if you are relying on this new default behavior then your usage is also affected.\n\nNote that none of these vulnerabilities significantly affect the installation of source distributions which are tar archives as source distributions already allow arbitrary code execution during the build process. However when evaluating source distributions it's important to avoid installing source distributions with suspicious links.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Bypass extraction filter to modify file metadata outside extraction directory","id":"CVE-2024-12718","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":13,"next":{"headline":"WordPress File Upload \u003c= 4.24.15 - Missing Authorization to Authenticated (Subscriber+) Limited Path Traversal","id":"CVE-2024-12719"},"packages":[{"ecosystem":"Bitnami","fixed":["3.9.23","3.10.18","3.11.13","3.12.11","3.13.4"],"introduced":["0","3.10.0","3.11.0","3.12.0","3.13.0"],"last_affected":[],"package":"libpython","purl":"pkg:bitnami/libpython","source":"BIT-libpython-2024-12718"},{"ecosystem":"Bitnami","fixed":["3.9.23","3.10.18","3.11.13","3.12.11","3.13.4"],"introduced":["0","3.10.0","3.11.0","3.12.0","3.13.0"],"last_affected":[],"package":"python","purl":"pkg:bitnami/python","source":"BIT-python-2024-12718"},{"ecosystem":"Bitnami","fixed":["3.9.23","3.10.18","3.11.13","3.12.11","3.13.4"],"introduced":["0","3.10.0","3.11.0","3.12.0","3.13.0"],"last_affected":[],"package":"python-min","purl":"pkg:bitnami/python-min","source":"BIT-python-min-2024-12718"}],"prev":{"headline":"aklamator-infeed \u003c= 2.0.0 - Admin+ Stored XSS","id":"CVE-2024-12717"},"products":["CPython"],"published":"2025-06-03","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-31","vendors":["Python Software Foundation"]},"summary":"Attackers can modify file metadata or permissions outside the extraction directory when using specific tarfile extraction filters.","url":"https://insights.sbomify.com/CVE-2024-12718/"}