# CVE-2024-12744: SQL Injection in the Amazon Redshift JDBC Driver affecting v2.1.0.31

> A SQL injection vulnerability in the Amazon Redshift JDBC Driver allows attackers to escalate privileges via metadata APIs, requiring an upgrade to the latest version.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Dec 2024
- **Updated:** 14 Oct 2025
- **Also known as:** GHSA-8596-2jgr-ppj7

## What is CVE-2024-12744?

CVE-2024-12744 is a high-severity SQL injection vulnerability in Amazon Redshift JDBC Driver, published on 24 Dec 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A SQL injection in the Amazon Redshift JDBC Driver in v2.1.0.31 allows a user to gain escalated privileges via the getSchemas, getTables, or getColumns Metadata APIs. Users should upgrade to the driver version 2.1.0.32 or revert to driver version 2.1.0.30.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-12744?

2 open source packages ship an affected version, including com.amazon.redshift:redshift-jdbc42. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.amazon.redshift:redshift-jdbc42` | Maven | From 2.1.0.31 | 2.1.0.32 |
| `com.amazon.redshift:redshift-jdbc42` | Maven | From 2.1.0.31 | 2.1.0.32 |

Products: Amazon Amazon Web Services Redshift Java Database Connectivity Driver.

## How do I fix CVE-2024-12744?

Upgrade com.amazon.redshift:redshift-jdbc42 to 2.1.0.32 or later.

## Is CVE-2024-12744 being exploited?

There is no known exploitation of CVE-2024-12744 in the wild and no public exploit code.

## Other vulnerabilities in Amazon Redshift JDBC Driver

- [CVE-2022-41828](https://insights.sbomify.com/CVE-2022-41828/): com.amazon.redshift:redshift-jdbc42 vulnerable to remote command execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-12744 and fix it if it is affected.

What it is: CVE-2024-12744 is a high-severity SQL injection vulnerability in Amazon Redshift JDBC Driver, published on 24 Dec 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-12744 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.amazon.redshift:redshift-jdbc42 (Maven): affected from 2.1.0.31; fixed in 2.1.0.32
- com.amazon.redshift:redshift-jdbc42 (Maven): affected from 2.1.0.31; fixed in 2.1.0.32

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-12744/ (Markdown: https://insights.sbomify.com/CVE-2024-12744/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-12744
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-12744
- OSV: https://osv.dev/vulnerability/CVE-2024-12744

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-12744/
Summaries are generated and may contain mistakes; the official description above is the record.
