CVE-2024-12797 RFC7250 handshakes with unauthenticated servers don't abort as expected

Medium 6.3 Published Updated

Attackers can perform man-in-the-middle attacks against TLS clients using Raw Public Keys if server authentication failures are not explicitly checked.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-12797?

CVE-2024-12797 is a medium-severity vulnerability in OpenSSL, published on 11 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Issue summary: Clients using RFC7250 Raw Public Keys (RPKs) to authenticate a server may fail to notice that the server was not authenticated, because handshakes don't abort as expected when the SSL_VERIFY_PEER verification mode is set.

Impact summary: TLS and DTLS connections using raw public keys may be vulnerable to man-in-middle attacks when server authentication failure is not detected by clients.

RPKs are disabled by default in both TLS clients and TLS servers. The issue only arises when TLS clients explicitly enable RPK use by the server, and the server, likewise, enables sending of an RPK instead of an X.509 certificate chain. The affected clients are those that then rely on the handshake to fail when the server's RPK fails to match one of the expected public keys, by setting the verification mode to SSL_VERIFY_PEER.

Clients that enable server-side raw public keys can still find out that raw public key verification failed by calling SSL_get_verify_result(), and those that do, and take appropriate action, are not affected. This issue was introduced in the initial implementation of RPK support in OpenSSL 3.2.

The FIPS modules in 3.4, 3.3, 3.2, 3.1 and 3.0 are not affected by this issue.

Weakness: CWE-392

Which versions are affected by CVE-2024-12797?

3 open source packages ship an affected version, including cryptography.

PackageAffectedFixed in
cryptography PyPIFrom 42.0.044.0.1
cryptography PyPIFrom 42.0.044.0.1
cryptography PyPIFrom 42.0.044.0.1
Linux distribution packages (23)
openssl AlmaLinux:9All versions1:3.2.2-6.el9_5.1
openssl-devel AlmaLinux:9All versions1:3.2.2-6.el9_5.1
openssl-libs AlmaLinux:9All versions1:3.2.2-6.el9_5.1
openssl-perl AlmaLinux:9All versions1:3.2.2-6.el9_5.1
openssl Red Hat:enterprise_linux:10.0All versions1:3.2.2-16.el10
openssl-debuginfo Red Hat:enterprise_linux:10.0All versions1:3.2.2-16.el10
openssl-debugsource Red Hat:enterprise_linux:10.0All versions1:3.2.2-16.el10
openssl-devel Red Hat:enterprise_linux:10.0All versions1:3.2.2-16.el10
openssl-libs Red Hat:enterprise_linux:10.0All versions1:3.2.2-16.el10
openssl-libs-debuginfo Red Hat:enterprise_linux:10.0All versions1:3.2.2-16.el10
openssl-perl Red Hat:enterprise_linux:10.0All versions1:3.2.2-16.el10
openssl-debuginfo Red Hat:enterprise_linux:9::appstreamAll versions1:3.2.2-6.el9_5.1
openssl-debugsource Red Hat:enterprise_linux:9::appstreamAll versions1:3.2.2-6.el9_5.1
openssl-devel Red Hat:enterprise_linux:9::appstreamAll versions1:3.2.2-6.el9_5.1
openssl-libs-debuginfo Red Hat:enterprise_linux:9::appstreamAll versions1:3.2.2-6.el9_5.1
openssl-perl Red Hat:enterprise_linux:9::appstreamAll versions1:3.2.2-6.el9_5.1
openssl Red Hat:enterprise_linux:9::baseosAll versions1:3.2.2-6.el9_5.1
openssl-debuginfo Red Hat:enterprise_linux:9::baseosAll versions1:3.2.2-6.el9_5.1
openssl-debugsource Red Hat:enterprise_linux:9::baseosAll versions1:3.2.2-6.el9_5.1
openssl-libs Red Hat:enterprise_linux:9::baseosAll versions1:3.2.2-6.el9_5.1
openssl-libs-debuginfo Red Hat:enterprise_linux:9::baseosAll versions1:3.2.2-6.el9_5.1
openssl Rocky Linux:9All versions1:3.2.2-6.el9_5.1
openssl-3 openSUSE:TumbleweedAll versions3.2.4-1.1

How do I fix CVE-2024-12797?

Upgrade cryptography to 44.0.1 or later.

Is CVE-2024-12797 being exploited?

There is no known exploitation of CVE-2024-12797 in the wild and no public exploit code.

Sources

Also known as ALPINE-CVE-2024-12797, ALSA-2025:1330, AZL-56761, AZL-56774, AZL-78591, BELL-CVE-2024-12797 and 19 more.

Is CVE-2024-12797 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free