{"answers":{"affected":"3 open source packages ship an affected version, including github.com/ollama/ollama.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12886 exists.","fix":"Upgrade github.com/ollama/ollama to 0.4.0-ci1 or later.","what":"CVE-2024-12886 is a high-severity denial of service vulnerability in ollama/ollama, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-12886 and fix it if it is affected.\n\nWhat it is: CVE-2024-12886 is a high-severity denial of service vulnerability in ollama/ollama, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12886 exists.\n\nAffected packages and fixed versions:\n- github.com/ollama/ollama (Go): affected all versions up to 0.3.14; no fix listed\n- github.com/ollama/ollama (Go): affected all versions up to 0.3.14; no fix listed\n- github.com/ollama/ollama (Go): affected all versions; fixed in 0.4.0-ci1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-12886/ (Markdown: https://insights.sbomify.com/CVE-2024-12886/index.md)","id":"CVE-2024-12886","markdown":"https://insights.sbomify.com/CVE-2024-12886/index.md","name":"CVE-2024-12886","record":{"aliases":["GHSA-v464-r2r9-www7","GO-2025-3548"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM server","requires_auth":"none","summary":"A malicious API server can crash the Ollama server by sending a gzip bomb, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"}],"description":"An Out-Of-Memory (OOM) vulnerability exists in the `ollama` server version 0.3.14. This vulnerability can be triggered when a malicious API server responds with a gzip bomb HTTP response, leading to the `ollama` server crashing. The vulnerability is present in the `makeRequestWithRetry` and `getAuthorizationToken` functions, which use `io.ReadAll` to read the response body. This can result in excessive memory usage and a Denial of Service (DoS) condition.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":"2026-05-19","github_poc":2,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-05-19T22:25:32Z","kind":"github_poc","ref":"https://github.com/dannyEndorTest/ollama","stars":0,"title":"EXPOSURE demo target (ollama) — HOT baseline for CVE-2024-12886. See README."},{"date":"2026-05-20T04:16:43Z","kind":"github_poc","ref":"https://github.com/dannyEndorTest/ollama-consumer","stars":0,"title":"Demo consumer for ollama v0.5.0 (vulnerable range for CVE-2024-12886) — endorctl scan target"}],"tier":"weaponised"},"has_fix":true,"headline":"Out-Of-Memory (OOM) Vulnerability in ollama/ollama","id":"CVE-2024-12886","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"code-projects Online Exam Mastering System update.php sql injection","id":"CVE-2024-12890"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":["0.3.14"],"package":"github.com/ollama/ollama","purl":null,"source":"GHSA-v464-r2r9-www7"},{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":["0.3.14"],"package":"github.com/ollama/ollama","purl":"pkg:golang/github.com/ollama/ollama","source":"GHSA-v464-r2r9-www7"},{"ecosystem":"Go","fixed":["0.4.0-ci1"],"introduced":["0"],"last_affected":[],"package":"github.com/ollama/ollama","purl":"pkg:golang/github.com/ollama/ollama","source":"GO-2025-3548"}],"prev":{"headline":"Connections Business Directory \u003c= 10.4.66 - Authenticated (Admin+) Arbitrary Directory Deletion","id":"CVE-2024-12885"},"products":["ollama/ollama"],"published":"2025-03-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-15","vendors":["ollama"]},"summary":"A malicious API server can crash the Ollama server by sending a gzip bomb, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2024-12886/"}