# CVE-2024-12909: SQL Injection to RCE in run-llama/llama_index

> Attackers can exploit SQL injection in the FinanceChatLlamaPack to achieve remote code execution via PostgreSQL large objects.

- **Severity:** Critical 10.0 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-x48g-hm9c-ww42, PYSEC-2026-398

## What is CVE-2024-12909?

CVE-2024-12909 is a critical SQL injection vulnerability in run-llama/llama_index, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in the FinanceChatLlamaPack of the run-llama/llama_index repository, versions up to v0.12.3, allows for SQL injection in the `run_sql_query` function of the `database_agent`. This vulnerability can be exploited by an attacker to inject arbitrary SQL queries, leading to remote code execution (RCE) through the use of PostgreSQL's large object functionality. The issue is fixed in version 0.3.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-12909?

3 open source packages ship an affected version, including llama-index-packs-finchat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-packs-finchat` | PyPI | All versions to 0.3.0 | None |
| `llama-index-packs-finchat` | PyPI | All versions to 0.3.0 | None |
| `llama-index-packs-finchat` | PyPI | All versions to 0.3.0 | None |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2024-12909?

No fix has been published for CVE-2024-12909 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-12909 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12909 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-23751](https://insights.sbomify.com/CVE-2024-23751/): SQL injection in llama-index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-12909 and fix it if it is affected.

What it is: CVE-2024-12909 is a critical SQL injection vulnerability in run-llama/llama_index, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12909 exists.

Affected packages and fixed versions:
- llama-index-packs-finchat (PyPI): affected all versions up to 0.3.0; no fix listed
- llama-index-packs-finchat (PyPI): affected all versions up to 0.3.0; no fix listed
- llama-index-packs-finchat (PyPI): affected all versions up to 0.3.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-12909/ (Markdown: https://insights.sbomify.com/CVE-2024-12909/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-12909
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-12909
- OSV: https://osv.dev/vulnerability/CVE-2024-12909

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-12909/
Summaries are generated and may contain mistakes; the official description above is the record.
