# CVE-2024-12910: Denial of Service in run-llama/llama_index

> An attacker can cause a denial of service in the llama_index library by triggering infinite recursion via a crafted URL in the KnowledgeBaseWebReader class.

- **Severity:** Medium 4.2 (`CVSS:3.0/AV:P/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-jvpf-xf32-2w4q, PYSEC-2025-11

## What is CVE-2024-12910?

CVE-2024-12910 is a medium-severity denial of service vulnerability in run-llama/llama_index, published on 20 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability in the `KnowledgeBaseWebReader` class of the run-llama/llama_index repository, version latest, allows an attacker to cause a Denial of Service (DoS) by controlling a URL variable to contain the root URL. This leads to infinite recursive calls to the `get_article_urls` method, exhausting system resources and potentially crashing the application.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2024-12910?

3 open source packages ship an affected version, including llama-index. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index` | PyPI | All versions | 0.12.9 |
| `llama-index` | PyPI | All versions | 0.12.9 |
| `llama-index` | PyPI | All versions | 0.12.9 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2024-12910?

Upgrade llama-index to 0.12.9 or later.

## Is CVE-2024-12910 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12910 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-12910 and fix it if it is affected.

What it is: CVE-2024-12910 is a medium-severity denial of service vulnerability in run-llama/llama_index, published on 20 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12910 exists.

Affected packages and fixed versions:
- llama-index (PyPI): affected all versions; fixed in 0.12.9
- llama-index (PyPI): affected all versions; fixed in 0.12.9
- llama-index (PyPI): affected all versions; fixed in 0.12.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-12910/ (Markdown: https://insights.sbomify.com/CVE-2024-12910/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-12910
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-12910
- OSV: https://osv.dev/vulnerability/CVE-2024-12910

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-12910/
Summaries are generated and may contain mistakes; the official description above is the record.
