CVE-2024-12911 SQL Injection in run-llama/llama_index

High 7.1 Published Updated

SQL injection in llama_index allows attackers to create arbitrary files and cause denial of service via prompt injection.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-12911?

CVE-2024-12911 is a high-severity SQL injection vulnerability in run-llama/llama_index, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A vulnerability in the `default_jsonalyzer` function of the `JSONalyzeQueryEngine` in the run-llama/llama_index repository allows for SQL injection via prompt injection. This can lead to arbitrary file creation and Denial-of-Service (DoS) attacks. The vulnerability affects the latest version and is fixed in version 0.5.1.

Weakness: CWE-89

Which versions are affected by CVE-2024-12911?

3 open source packages ship an affected version, including llama-index. It affects 1 product.

PackageAffectedFixed in
llama-index PyPIAll versions0.12.3
llama-index PyPIAll versions0.12.3
llama-index PyPIAll versions0.12.3

Products include Llamaindex Llamaindex.

How do I fix CVE-2024-12911?

Upgrade llama-index to 0.12.3 or later.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2024-12911 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12911 exists.

Sources

Also known as GHSA-jmgm-gx32-vp4w, PYSEC-2026-1555.

Is CVE-2024-12911 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free