# CVE-2024-12911: SQL Injection in run-llama/llama_index

> SQL injection in llama_index allows attackers to create arbitrary files and cause denial of service via prompt injection.

- **Severity:** High 7.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-jmgm-gx32-vp4w, PYSEC-2026-1555

## What is CVE-2024-12911?

CVE-2024-12911 is a high-severity SQL injection vulnerability in run-llama/llama_index, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability in the `default_jsonalyzer` function of the `JSONalyzeQueryEngine` in the run-llama/llama_index repository allows for SQL injection via prompt injection. This can lead to arbitrary file creation and Denial-of-Service (DoS) attacks. The vulnerability affects the latest version and is fixed in version 0.5.1.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-12911?

3 open source packages ship an affected version, including llama-index. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index` | PyPI | All versions | 0.12.3 |
| `llama-index` | PyPI | All versions | 0.12.3 |
| `llama-index` | PyPI | All versions | 0.12.3 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2024-12911?

Upgrade llama-index to 0.12.3 or later.

## Is CVE-2024-12911 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12911 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-12911 and fix it if it is affected.

What it is: CVE-2024-12911 is a high-severity SQL injection vulnerability in run-llama/llama_index, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-12911 exists.

Affected packages and fixed versions:
- llama-index (PyPI): affected all versions; fixed in 0.12.3
- llama-index (PyPI): affected all versions; fixed in 0.12.3
- llama-index (PyPI): affected all versions; fixed in 0.12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-12911/ (Markdown: https://insights.sbomify.com/CVE-2024-12911/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-12911
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-12911
- OSV: https://osv.dev/vulnerability/CVE-2024-12911

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-12911/
Summaries are generated and may contain mistakes; the official description above is the record.
